Beiträge durchsuchen

Keine externen Verbindungen möglich

Startseite Foren VoIP-Telefonie FreePBX / Asterisk Keine externen Verbindungen möglich

Ansicht von 11 Beiträgen - 1 bis 11 (von insgesamt 11)
  • Autor
    Beiträge
  • #1179
    Matthias SoikaMatthias Soika
    Teilnehmer

      Hallo

      vielen Dank erst einmal für die umfangreichen Tutrorials über dir FreePBX. Sehr informativ. Wirklich kann man nicht anders sagen.

      Ok bevor ich hier tiefgründig werde wollte ich ursprünglich eins erreichen. Von der Internet Seite aus über einen Sip Client auf meinem Mobil Telefon ein Telefonat zu führen. Hierfür bietet zumindest meine Fritzbox auch eine Option.

      Fritz Box Telefonie

      In diesem Fall ist das anmelden an dieser Stelle aus dem Internet nicht zulässig aber an einer anderen hatte ich die Checkbox aktiviert. Meine Acrobits app hat mir auch gesagt, dass sie sich verbunden hat. Soweit ok. Wenn ich dann von Intern aus meinem WLan z.b. Telefonieren wollte war und ist das auch bis heute kein Problem. Von der Internet seite allerdings klingelt die Nebenstelle aber man hört nichts. Ok habe ich mir gedacht versuchst du doch mal das Ganze mit einer Telefonanlage. Naheliegend war hier natürlich die freepbx.

      Also das System hier zuhause auf meinem Hyper V Server installiert. Grundeinstellungen gesetzt und fertig. Erst mal zum Spielen ein paar Nebenstellen angelegt. Wunderbar hier im Heimischen Netzwerk funktioniert das wunderbar. Also vom Phonerlite zu acrobits und umgekehrt geht.

      Als nächstes habe ich auf meiner Fritzbox alle Rufnummern gelöscht. Habe natürlich vorher ein Backup von der Konfiguration gemacht. Fritzbox neu gestartet und siehe da der Port 5060 war deaktiviert. Ich die entsprechenden Portweiterleitungen an die freepbx angelegt. Getestet, geht. Wunderbar. Allerdings habe ich es nicht hinbekommen meine 3 Rufnummern von der Telekom an der PBX zu registrieren. Schade. Für den Abend war dann erst mal Schluss. Das Backup wieder eingespielt und die Telefonie über die Fritzbox war wieder funktionsfähig.

      Anlauf Nummer 2 verlief dann so dass ich mir gedacht habe ok. Dann ist die Fritzbox eben dein Trunkanbieter. Ich also 2 neue Telefoniegeräte in der Frizbox angelegt und als Trunk auf der PBX angelegt. Das wiederum geht wunderbar. Also habe ich im nächsten Schritt den Standard SIP Port von 5060 auf 5090 gelegt. Die PBX neu gestartet. Trunk ist registriert. Die SIP Clients angepasst und siehe da ich bin tatsächlich in der Lage vom LAN aus intern und extern zu telefonieren. Begeisterung macht sich bei mir breit. Am nächsten Tag kam dann auch gleich die Enttäuschung. Vom Internet aus geht es immer noch nicht. Mir ist dann aufgefallen, dass man den RTP Port Range noch als Portregel in der Fritzbox hinzufügen. Und jetzt kommts. Es geht trotzdem nicht!

      Ich vermute das es an der Fritz box liegt. Dass die irgendwas abfängt oder SIP Magic versucht und sich das negativ auf das erwartete verhalten auswirkt. Gibt es hier eine Möglichkeit noch was einzustellen? Wie kann ich ermitteln woran der Fehler liegt? Hat jemand schon mal versucht sich mit einem gewöhnlichem Telekom Hausanschluss von der Internet Seite aus an einer PBX zu registrieren und zu telefonieren?

      Im übrigen ist die Sip client Registrierung erfolgreich. Und die Nebenstelle Klingelt auch. Wenn man dann das Telefonat annehmen möchte Hört man aber die andere Seite nicht und man selbst wird auch nicht gehört. Ich habe den verdacht das sich das Real-Time Transport Protocol nicht richtig indizieren lässt. Wahrscheinlich durch das Natting der Fritzbox.

      Jemand eine Idee?

      Freundliche Grüße

      Matthias

      #1892
      Matthias SoikaMatthias Soika
      Teilnehmer

        Hallo,

        mir ist bewusst das es nun schon ein paar Monde her ist als ich diese anfrage gestellt habe. Mittlerweile kann ich sagen das ich das Problem gelößt habe! Es war alles andere als einfach.

        Die Lösung ist die FreePBX nicht via IPv4 sondern IPv6 only zu betreiben. Ich habe den Netzwerk verkehr abfangen und festgestellt das wenn ich über das Internet rein gekommen bin das RTP nicht initiiert werden konnte da wahrscheinlich meine Fritzbox oder mein ISP das verhindert.

        Da IPv6 kein NAT vorsieht und es an meinem Telefon auch anliegt wenn ich 3,4 oder 5G empfang habe wird die Verbindung ohne Schwierigkeiten aufgebaut. Ich verwende auf meinem Fairphone 4 den Groundwire SIP Client mit SRTP und TLS.  Funktioniert Tadellos. Habe ich schon mehrfach getestet. Es ist schön wenn man auch auf seiner Festnetznummer unterwegs erreichbar ist.

        Falls es gewünscht ist stelle ich auch gerne ein HOWTO dafür bereit, wenn nicht ist es auch ok.

        Grüße

        Matthias

        #1893
        Gundolf BachmannDunsi
        Teilnehmer

          Hallo, wäre es nicht einfacher mit einer VPN Verbindung in Dein privates Netz vom Handy aus gegangen? Dann kannst Du Dich ja über Deine FreePBX überall hin verbinden. Sorry, aber ich habs jetzt erst gelesen…

          #1894
          Matthias SoikaMatthias Soika
          Teilnehmer

            Ja klar wäre das in der Theorie ein gangbarer weg, allerdings möchte ich ja nicht nur Rausrufen sondern auch per “Festnetz” erreichbar sein. Dies bedeutet ja das ich immer und zu jeder Zeit eine VPN Verbindung offen halten müsste. Das ist für mich keine Lösung. Es muss in meinem Fall zwangsläufig ohne VPN machbar sein.

            #1895

            Hatte mit der FritzBox auch Probleme, dass die RTP Ports nicht aufwaren. Man kann keine Port-Range an der Fritzbox freigeben sondern nur einzelne Ports. Das ist etwas umständlich.
            Gelöst habe ich es, indem ich die Ports (100 Stück) via UPNP vom Raspberry aus aufgemacht habe. Seitdem keine Verbindungsprobleme mehr von außerhalb. Allerdings muss ich am Smartphone 2 SIP-Profilie haben. Einen für’s LAN mit IP und eines für außerhalb mit XXX.myfritz.net

            #1896
            Matthias SoikaMatthias Soika
            Teilnehmer

              Na das schöne an der Konfiguration ist das in meinem LAN und WLAN sowie im Internet die IPv6 Adresse von meiner FreePBX immer die selbe ist. Deshalb ist auch ein Netzwechsel unkritisch. Ich habe das getestet. Ich war bei meinem Nachbarn und mit seinem WLAN verbunden. Hab dann seine Festnetznummer über mein Softfon (Groudwire) angerufen. Die Verbindung wurde wie erwartet aufgebaut. Dann haben wir beide erzählt und ich bin dann rüber zu mir, dabei verlor ich die Verbindung zu seinem WLAN und war dann im 5G. In diesem Moment hat man auch eine kleine Unterbrechung gehört (kurz Stumm) wurde dann aber sofort wieder aufgebaut. Und dann noch mal eine kurze Unterbrechung beim betreten meines WLAN’s daheim. Also ich muss sagen davon bin ich echt begeistert.

              #1897
              Gundolf BachmannDunsi
              Teilnehmer

                Bedeutet das, dass die FreepBX nun IPv6 mäßig im öffentlichen Netz hängt ohne Firewall oder ähnlichem?

                Wäre es also möglich, wenn ich die IP Adresse der FreePBX hätte, mich dort einzuloggen?

                #1898
                Matthias SoikaMatthias Soika
                Teilnehmer

                  Ja das ist richtig. Sie hat eine Öffentliche Global unicast Adresse. Und ja es gibt vor der FreePBX keine weitere Firewall. Das wollte ich auch nicht, denn die FreePBX bringt eine leistungsstarke Firewall mit die ja dann bei Login versuchen die Angreifer automaisch aussperrt.

                  Und ja, wenn du die IP Adresse hättest könntest du theoretisch wenn du zugangsdaten von meiner Anlage hättest dich dort anmelden, registrieren etc.

                  Der positive Nebeneffekt ist das es keine Angriffe auf das System gibt. Die IP Adresse ist völlig wahllos gewählt. Einen IPv4 Bereich abzuscannen ist eine Aufgabe von ein paar Minuten, bei IPv6 würde das Tage dauern. Weil einfach die Bereiche so exorbitant riesig sind.

                  #2350
                  Matthias SoikaMatthias Soika
                  Teilnehmer

                    Hi allerseits,

                    es ist schon ein paar Tage her das ich mich zu diesem Thema gemeldet habe. Nun habe ich es auch per IPv4 hinbekommen. Ich musste hier noch mal zeit investieren da mein aktueller Arbeitgeber kein IPv6 in seinem WLan anbietet wollte ich das noch mal mit IPv4 testen. Ich habe auch die Lösung gefunden.

                    Damit das auch zuverlässig über IPv4 Funktioniert muss zwingend die Öffentliche IP-Adresse nicht der FQDN des FreePBX unter Einstellungen -> Asterisk SIP Settings -> Externe Adresse hinterlegt sein.

                    Damit ich das nicht immer händisch machen muss nach dem sich meine Fritzbox neu eingewählt hat, habe ich dafür ein kleines Shell Skript geschrieben.

                    #!/bin/bash

                    FwConsole=$(which fwconsole)
                    MySQL=$(which mysql)
                    CurrentIPinCfg=$($MySQL -u root -Bse ‘SELECT val FROM asterisk.kvstore_Sipsettings where key = “externip”;’)
                    myPublicIPv4Address=$($FwConsole extip)
                    curlResult=$?

                    if [ $curlResult -ne 0 ]; then echo; echo “Fehler beim ermitteln der Public IP!”; echo; exit 2; fi

                    #echo CurrentIPinCfg: $CurrentIPinCfg
                    #echo My Public IPv4 Adress: $myPublicIPv4Address

                    if [ ! $CurrentIPinCfg = $myPublicIPv4Address ]; then
                    $MySQL -u root –verbose -Bse ‘update asterisk.kvstore_Sipsettings set val=’\”$myPublicIPv4Address\”‘ where key=”externip”;’
                    $FwConsole reload
                    fi

                    Dieses läuft alle 5 Minuten und aktualisiert bei bedarf den Wert in der MySQL Datenbank.

                    Grüße Matthias

                    #2352
                    jgriebjgrieb
                    Administrator

                      Mit einer festen öffentlichen IP-Adresse oder einer DynDNS Domain in den SIP-Einstellungen der FreePBX funktioniert es mit IPV4 auch und man kann sich den restlichen Aufwand sparen.

                      Grüsse

                      #2353
                      Matthias SoikaMatthias Soika
                      Teilnehmer

                        Mag sein, das will ich nicht in abrede stellen. Vielleicht liegt es auch an meinem Acrobits Groundwire Softfone auf meinem Handy. Mit meinem DynDNS Hostnamen habe ich es nicht zum laufen bekommen.

                        Grüße

                      Ansicht von 11 Beiträgen - 1 bis 11 (von insgesamt 11)
                      • Du musst angemeldet sein, um auf dieses Thema antworten zu können.