Beiträge durchsuchen

Themenreihe FreePBX 15/Asterisk 16-Teil 2.2.1. Umschalten auf DNS-SRV-Lookup

 

Die Telekom schaltet derzeit die DNS-Auflösung Ihrer ALL-IP-Anschlüsse von A-Record auf SRV-Record um. Die Nutzer der betroffenen Anschlüsse erhalten einen Brief mit dem folgenden oder ähnlichem Inhalt:

“… haben wir festgestellt, dass Ihre Router statt einer SRV-Diensteauflösung einen veralteten DNS-Konfigurationseintrag über A-Record nutzen, den die aktuelle Plattform ab Herbst nicht mehr unterstützt.
Um auch künftig telefonieren zu können, müssen Sie die aktuellste Firmware auf Ihren umseitig aufgeführten Routern installieren. Dafür genügt in der Regel ein einfaches Update…”

Was ist in der FreePBX zu tun, damit die Telefonie auch nach dieser Umstellung noch reibungslos funktioniert?

Wenn in der Konfiguration der Hauptleitung der pjsip-Kanaltreiber verwendet wird (pjsip-Hauptleitung) dann sollte der SRV-Lookup automatisch funktionieren. Falls nicht, dann kann der SRV-Lookup auch manuell aktiviert werden.

Die Details dazu gibt’s wie immer immer im Video.

7 Kommentare zu Themenreihe FreePBX 15/Asterisk 16-Teil 2.2.1. Umschalten auf DNS-SRV-Lookup

    1. Hallo,
      ich gehe in meiner Antwort mal davon aus, dass Sie chan_sip meinen.
      Um für chan_sip den SRV-Lookaup zu aktivieren gehen Sie in der FreePBX-Verwaltungsoberfläche auf Einstellungen / Asterisk SIP-Settings und klicken dort auf den Reiter SIP Legacy Settings [chan_sip].
      Scrollen Sie ganz nach unten. Dort finden Sie den Parameter “Enable SRV Lookup”. Diesen Parameter müssen Sie auf “Ja” setzen.
      Der chan_sip-Kanaltreiber ist aber veraltet und nur noch aus Kompatibilitätsgründen vorhanden. Ich empfehle dringend auf chan_pjsip zu wechseln.
      Grüße

      1. Danke für die Info! Wechsel auf chan_pjsip ist auf meine ToDo Liste. Hatte damit auch gestartet, jedoch brachen Gespräche nach 30s ab. Mit chan_sip funktioniert es…

  1. Kurze Rückmeldung:
    Uns hatte es jetzt am Wochenende erwischt. Obwohl nur pjsip im Einsatz ist (bei 10 Rufnummern) mussten wir jeweils den Port rauslöschen. Danach hat es sofort wieder funktioniert.

    Vielen Dank für die wieder einmal wertvolle Info!

  2. Vielen Dank für diese Info, musste auch an jeder Nummer die Ports entfernen. Danch ging es sofort wieder wie gewohnt weiter.

  3. Hallo, habe bei zwei FreePBX Anlagen den Port in den PJSIP Einstellungen auf allen Hauptleitungen entfernt und bei beiden Anlagen schien es zu funktionieren.
    Am nächsten Tag waren aber bei beiden Anlagen alle Hauptleitungen offline.
    Nach einem Reboot kamen sie aber wieder hoch.
    Mal schauen wie lange…

    1. Leider haben auch am nächsten Tag beide Anlagen die Registrierung auf den Hauptleitungen verloren.
      Im Log erscheint nur: No response received from ‘sip:tel.t-online.de’ on registration attempt to ‘sip:0xxxxxxxxx@tel.t-online.de’, retrying in ’60’.
      Ich habe den Port 5060 wieder eingetragen und seit dem bleibt es stabil.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.