Beiträge durchsuchen

Themenreihe FreePBX 15/Asterisk 16-Teil 2.2.1. Umschalten auf DNS-SRV-Lookup

 

Die Telekom schaltet derzeit die DNS-Auflösung Ihrer ALL-IP-Anschlüsse von A-Record auf SRV-Record um. Die Nutzer der betroffenen Anschlüsse erhalten einen Brief mit dem folgenden oder ähnlichem Inhalt:

“… haben wir festgestellt, dass Ihre Router statt einer SRV-Diensteauflösung einen veralteten DNS-Konfigurationseintrag über A-Record nutzen, den die aktuelle Plattform ab Herbst nicht mehr unterstützt.
Um auch künftig telefonieren zu können, müssen Sie die aktuellste Firmware auf Ihren umseitig aufgeführten Routern installieren. Dafür genügt in der Regel ein einfaches Update…”

Was ist in der FreePBX zu tun, damit die Telefonie auch nach dieser Umstellung noch reibungslos funktioniert?

Wenn in der Konfiguration der Hauptleitung der pjsip-Kanaltreiber verwendet wird (pjsip-Hauptleitung) dann sollte der SRV-Lookup automatisch funktionieren. Falls nicht, dann kann der SRV-Lookup auch manuell aktiviert werden.

Die Details dazu gibt’s wie immer immer im Video.

29 Kommentare zu Themenreihe FreePBX 15/Asterisk 16-Teil 2.2.1. Umschalten auf DNS-SRV-Lookup

    1. Hallo,
      ich gehe in meiner Antwort mal davon aus, dass Sie chan_sip meinen.
      Um für chan_sip den SRV-Lookaup zu aktivieren gehen Sie in der FreePBX-Verwaltungsoberfläche auf Einstellungen / Asterisk SIP-Settings und klicken dort auf den Reiter SIP Legacy Settings [chan_sip].
      Scrollen Sie ganz nach unten. Dort finden Sie den Parameter “Enable SRV Lookup”. Diesen Parameter müssen Sie auf “Ja” setzen.
      Der chan_sip-Kanaltreiber ist aber veraltet und nur noch aus Kompatibilitätsgründen vorhanden. Ich empfehle dringend auf chan_pjsip zu wechseln.
      Grüße

      1. Danke für die Info! Wechsel auf chan_pjsip ist auf meine ToDo Liste. Hatte damit auch gestartet, jedoch brachen Gespräche nach 30s ab. Mit chan_sip funktioniert es…

  1. Kurze Rückmeldung:
    Uns hatte es jetzt am Wochenende erwischt. Obwohl nur pjsip im Einsatz ist (bei 10 Rufnummern) mussten wir jeweils den Port rauslöschen. Danach hat es sofort wieder funktioniert.

    Vielen Dank für die wieder einmal wertvolle Info!

  2. Vielen Dank für diese Info, musste auch an jeder Nummer die Ports entfernen. Danch ging es sofort wieder wie gewohnt weiter.

  3. Hallo, habe bei zwei FreePBX Anlagen den Port in den PJSIP Einstellungen auf allen Hauptleitungen entfernt und bei beiden Anlagen schien es zu funktionieren.
    Am nächsten Tag waren aber bei beiden Anlagen alle Hauptleitungen offline.
    Nach einem Reboot kamen sie aber wieder hoch.
    Mal schauen wie lange…

    1. Leider haben auch am nächsten Tag beide Anlagen die Registrierung auf den Hauptleitungen verloren.
      Im Log erscheint nur: No response received from ‘sip:tel.t-online.de’ on registration attempt to ‘sip:0xxxxxxxxx@tel.t-online.de’, retrying in ’60’.
      Ich habe den Port 5060 wieder eingetragen und seit dem bleibt es stabil.

  4. Moin, und danke für die Anleitung. Anscheinend hat Vodafone nun auch umgestellt. Ich habe einen “alten” Arcor Zugang. Nach löschen des Ports 5060 bei PJSIP funktioniert es (wieder). Ich sehe auch mit Port eine Registrierung, doch kann ich keine Anrufe tätigen und auch keine empfangen. Ohne Port wird der Trunk auch registriert und Telefonate sind möglich. Nun zur Frage: gibt es eine Möglichkeit mit Hilfe des CLI die SVR Auflösung zu sehen? Oder loggen? Meine Suche bei FreePBX hat leider nicht viel ergeben.
    Danke schon mal. Und beleibt gesund.

    1. Soweit ich weiss nein.
      Aber was wollen Sie da auch sehen? Wenn der Port auf Null gestellt oder leer gelassen wird, löst der pjsip-Kanaltreiber definitiv über SRV-lookup auf. Port auf Null oder leer ist der Schalter dafür.
      Grüsse

      1. Es geht alles, man muss nur suchen. Warum ich das sehen will? ich will sehen, ob und was da aufgelöst wird. So als Bestätigung, dass es wirklich funktioniert. Bin halt Ingenieur und schaue gern hinter die Kulissen. Also für diejenigen, die es interessiert: SSH in die FreePBX mit Putty. Dann gibt man ein: host -t svr _sip._udp.089.sip.arcor.de (Beispielhaft für einen Münchner Sip Server). Man kann es auch mit TCP probieren, z.B. bei der Telekom.
        Gruß

        1. es geht sogar live: tcpdump -npi any udp port 53
          Dann sieht man, welche Amtsleitung (Trunk) auf welchen Sip Server zugreift.
          Danke für die Hilfe…

        2. Hallo,
          wenn in der Trunkkonfiguration das Feld für den Port leer ist, wird die Auflösung über SRV-Lookup zwingend aktiviert. Eine Auflösung über A-Record findet dann nicht mehr statt. Die Tatsache, dass nach dieser Konfigurationsänderung noch, bzw. wieder telefoniert werden kann, ist der eindeutige Beweis, dass SRV-Lookup in der FreePBX funktioniert.
          Insofern kann ich durch Verwendung dieses Befehls im konkreten Fall keinen Zugewinn an Erkenntnissen feststellen.
          Grüße

  5. Hallo Herr Grieb,
    danke für die tolle Erklärung und die Aufklärung der Situation.
    Hat mir viel Zeit ge- und einige graue Haar erspart.

    Ganz großes Kino,
    Danke!

  6. Bei uns ist es jetzt auch angekommen, ich hab leider nur das Problem das nach einem Tag der onnect verlohren geht…. das war vorher nicht so, ich muss dann jedesmal neustarten und dann läuft es wieder…. jemand eine Ahnung woran das liegen könnte oder wo ich mal schauen kann?

    1. Hallo,
      NAT in “Erweiterten Einstellungen” deaktivieren, STUN-Server wie in Teil 2.2. eintragen und dann noch mal testen.
      Eine feste IP bei aktivierten NAT könnte auch Abhilfe schaffen.
      Grüße

  7. Hallo, dass hat leider nicht funktioniert, nach 2 Tagen wieder das gleiche Problem, ich hab allerdings keine feste IP Adresse, ist es denn zwingend notwendig eine feste IP zu haben?
    Das hat ja vorher monate ohne Probleme funktioniert……

    1. Hallo,
      eigentlich sollte es auch ohne feste IP funktionieren. Ich hatte aber auch schon Kunden, bei denen das Problem ohne feste IP nicht zu lösen waren.
      Sie können noch eine Einstellung testen.
      – In Erweiterte Einstellungen NAT aktivieren
      – in Asterisk SIP-Einstellungen die STUN-Server entfernen und im Abschnitt NAT-Settings auf den Button Netzwerkeistellungen klicken. Dann Speichern und Apply Config klicken und noch mal testen.
      Grüße

  8. Sorry, aber ich hab da ein Verständnisproblem.
    @Daniel: wie registrieren sich die Amtsleitungen? Hast Du die FreePBX als Server?
    ich denke mal Du hast, wie die meisten hier, die FreePBX in einem privaten Netz und gehst über einen Router ins Web. Wenn das so ist, benötigt man weder einen STUN Server noch NAT, denn das erledigt ausgehend der Router. Immer wieder hilfreich ist auch das Asterisk Log File. Bei Abbruch mal reinschauen. Evtl. gibt es dort Erkenntnisse.
    Kann die FreePBX denn die Serveradresse der Amtsleitung auflösen? Stichwort ping. Was ist, wenn die Verbindung weg ist?
    Bei mir läuft das seit 2 Jahren ohne NAT, ohne STUN sowie ohne eingetragene IP Adressen, weder öffentlich noch lokal (bei Asterisk SIP Settings).
    Viel Erfolg.

  9. @Dunsi

    Ich hab ein Freepbx hinter dem Router, wie du beschrieben hast.
    Im Logfile sehe ich wie plötzlich die Gegenstelle also der Tel.t-onlime.de
    nicht mehr erreichbar ist.
    Dann versucht Freepbx neu zu verbinden, dass klappt dann auch aber eben nicht immer und dann bricht es ab.

  10. Immer gut, wenn man etwas Recherche betreibt. Ich bekomme auf der CLI der FreePBX nach dem Befehl, eine DNS-SRV Auflösung auf tel.t-online.de zumachen, folgendes Ergebnis:

    host -t srv _sip._tcp.tel.t-online.de
    _sip._tcp.tel.t-online.de has SRV record 20 0 5060 h2-epp-100.edns.t-ipnet.de.
    _sip._tcp.tel.t-online.de has SRV record 30 0 5060 d-epp-100.edns.t-ipnet.de.
    _sip._tcp.tel.t-online.de has SRV record 10 0 5060 n-epp-100.edns.t-ipnet.de.

    Bei einem normalen ping kann er die Adresse nicht auflösen.
    Hier, denke ich, liegt das Problem bei Daniel.
    Jetzt ist die Frage, welcher Router genutzt wird? Eine Fritzbox? Oder ein Telekom Router? Laut hier: https://www.sunds-computer.de/telekom-veralteter-dns-eintrag-router-update-noetig/ wäre ein Update notwendig.

  11. Hmmm… aber es ist merwkürdig das es dann mal geht und mal nicht geht…. oder?
    Ich sehe im Log keine Fehler ausser das wie gesagt plötzlich die Gegenstell nicht mehr erreichbar ist.
    Dann nach einem Versuch geht es wieder…. ich hab dann immer mal so 1-2 Minuten wo die Leitung nicht erreichbar ist.
    Ich habe hier einen Ubiquiti UniFi USG Security Gateway Router am laufen. Da der Unifi keine PPOE Einwahl kann hab ich ein billiges PPOE Modem davor noch laufen……

    1. Hallo Daniel,
      es ist schon etwas seltsam, dass die von mir veröffentlichte Konfiguration zum DNS SRV-Lookup beim Telekom Voice/Data-Anschluss bei fast allen Anwendern funktioniert und bei einigen Wenigen nicht.
      Ich habe mir auch schon Gedanken darüber gemacht, woran das liegen könnte und bin dabei zu folgendem Ergebnis gekommen:
      Ich denke, man kann davon ausgehen, dass die Voice/Data-Anschlüsse der Telekom technisch überall gleich sind. Alles andere wäre unlogisch und technischer Unsinn. Folglich kann die Ursache des Problems nur im Einflussbereich des Anwenders liegen. Ich denke auch das ist logisch. Nun ist dieser Einflussbereich aber nicht nur auf die FreePBX beschränkt. Dazu gehört die gesamte Netzwerkstruktur vom Router über Firewalls bis hin zur FreePBX. Sophos und pfSense-Firewalls benötigen hierbei z. B. eine besondere Aufmerksamkeit. Befindet sich die FreePBX obendrein auch noch in einem anderen Netzwerksegment wird es noch noch komplizierter. Diese Dinge nur mal so als Beispiel. Da gibt es noch viel mehr davon.
      Offensichtlich umgehst Du mit diesen Einstellungen ein Konfigurationsproblem an einer anderen Stelle. Aber wenn’s funktioniert ist alles ok.
      Ich freue mich, dass Deine FreePBX jetzt wieder funktioniert.
      Grüße

      1. Hi,
        ja, daher wundert es mich ja selber, aber besonders komplex ist meine Konfig hier nicht.
        Alles ein Netz, alle Clients inkl. der Freebpx sind in einem Netz, die Clients sind an einem Router angeschlossen, dass ist der Unifi Router, dass war es schon.
        Die Firewall und alles andere laufen auf dem Router, da gibts sonst nichts……
        Ich meine es hat ja mal super funktioniert, bis auf die Umstellung bei der Telekom… seitdem gehts halt nicht mehr so…. Ich hab auch am Netz nichts geändert… Keine IP, keine Firewall, keine Firmware…. nichts… noch nicht mal ein Update auf der Freepbx….

        1. Die Updates würde ich aber unbedingt machen. System-Updates und Modul-Updates. Die Aktualisierung der Software hat in meiner Praxis schon oft Probleme gelöst, für welche es keine Erklärung gab.
          Wenn Sie sich nicht sicher sind wie man das macht, dann warten Sie bitte bis zum Wochenende. Dann veröffentliche ein Video zu diesem Thema.
          Grüsse
          Grüsse

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.